Dashboard and payment pages not loading on Google Chrome v117
Resolved·Full outage

We haven't observed any loading issues since the fix was applied.

We do not expect any additional disruption.

Thu, Sep 14, 2023, 09:10 AM
(1 year ago)
·
Affected components
Updates

Resolved

We haven't observed any loading issues since the fix was applied.

We do not expect any additional disruption.

Thu, Sep 14, 2023, 09:10 AM

Monitoring

Our engineers have applied a fix and all pages are now loading successfully.

We are continuing to monitor the situation.

Wed, Sep 13, 2023, 02:57 PM(18 hours earlier)

Investigating

We are currently experiencing an outage of our Dashboard and Payment Pages while using the newest version of Google Chrome.

Our engineers have found the root cause and are working towards a solution, if you encounter a page-loading problem, please use another browser as a workaround.

Wed, Sep 13, 2023, 01:16 PM(1 hour earlier)