GBP Payouts delayed for merchants
Resolved

GBP Payouts were submitted at 16:50 BST. These payments should now have reached the destination accounts, as per the Faster Payments timings.

We do not expect any additional disruption.

Tue, Aug 2, 2022, 06:08 PM
(2 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

GBP Payouts were submitted at 16:50 BST. These payments should now have reached the destination accounts, as per the Faster Payments timings.

We do not expect any additional disruption.

Tue, Aug 2, 2022, 06:08 PM

Monitoring

Our engineers have identified the issue causing a delay in GBP payouts for merchants and are working to ensure payouts are processed today.

Tue, Aug 2, 2022, 03:44 PM(2 hours earlier)