NatWest and RBS banks unplanned downtime
Resolved

We have confirmed that Instant Bank Payments from NatWest and RBS are functioning as expected again.

Sat, Oct 5, 2024, 10:48 AM
(6 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

We have confirmed that Instant Bank Payments from NatWest and RBS are functioning as expected again.

Sat, Oct 5, 2024, 10:48 AM

Monitoring

NatWest and RBS banks have resolved the issue affecting Instant Bank Payments (IBPs) made to these banks. As a result, these banks will now appear on the list of institutions for Instant Bank Payments on the payer's side. We will continue monitoring the situation and provide another update soon.

Sat, Oct 5, 2024, 10:23 AM(25 minutes earlier)

Identified

NatWest and RBS banks are experiencing unplanned downtime. As a result, these banks will not appear on the list of institutions for Instant Bank Payments on the payer's side.

We are monitoring the situation and will provide updates as soon as possible.

Sat, Oct 5, 2024, 09:22 AM(1 hour earlier)