Merchants receiving potentially incorrect billing e-mails
Incident Report for GoCardless
Resolved
We’ve identified the merchants who were incorrectly contacted with an email requesting funds. We have reached out to these merchants to clarify the situation.
Posted Mar 07, 2024 - 07:23 GMT
Investigating
We are investigating reports of merchants who have received requests for funds that have already paid.

We are identifying those who have incorrectly received this message and will notify those impacted.
Posted Mar 06, 2024 - 10:54 GMT