Resolved
All affected GBP payouts have now been processed.
We apologise for the disruption and thank you for your patience.
Investigating
Affected GBP payouts are beginning to be processed. We are continuing to work closely with our banking partner to ensure all delayed payouts are completed as quickly as possible.
We will provide further updates once we see all payouts have been confirmed.
We appreciate your patience with this.
Investigating
Some customers are experiencing delays receiving GBP payouts. We are actively working with our bank partner to investigate the issue and confirm when affected payouts will be completed.
We apologise for the inconvenience and appreciate your patience.
Investigating
Some customers are experiencing delays receiving GBP payouts. We are actively working with our bank partner to investigate the issue and confirm when affected payouts will be completed.
We apologise for the inconvenience and appreciate your patience.
Investigating
Some customers may be experiencing delays receiving GBP payouts. We are investigating the issue with our banking partner and will provide an update as soon as more information is available.
We apologise for any inconvenience caused.