Direct Debit collection failures for BECS NZ
Investigating·Degraded performance

We are continuing to investigate the incident that has resulted in an increased number of Direct Debit collection failures for some New Zealand customers.

In addition to payments scheduled for 24th February, we have identified that some payments scheduled for 25th February are also impacted and there may be delays to processing these payments.

We are actively working with our banking partner to resolve this as quickly as possible. We will provide further updates as more information becomes available.

We will soon reach out to all affected merchants.

Wed, Feb 25, 2026, 03:16 PM
(7 hours ago)
·
Affected components
Updates

Investigating

We are continuing to investigate the incident that has resulted in an increased number of Direct Debit collection failures for some New Zealand customers.

In addition to payments scheduled for 24th February, we have identified that some payments scheduled for 25th February are also impacted and there may be delays to processing these payments.

We are actively working with our banking partner to resolve this as quickly as possible. We will provide further updates as more information becomes available.

We will soon reach out to all affected merchants.

Wed, Feb 25, 2026, 03:16 PM

Investigating

We are currently investigating an incident that has resulted in an increased number of Direct Debit collection failures for some New Zealand customers on 24th February.

We are working with our banking partner and will provide further updates as soon as more information becomes available.

Wed, Feb 25, 2026, 10:19 AM(4 hours earlier)