Monitoring
We’ve identified the root cause and implemented a fix. Access to the GoCardless dashboard should now be fully restored.
We’ll continue to monitor the system to ensure everything remains stable.
Investigating
We are continuing to investigate the issue affecting the dashboard, including reports of users seeing a blank screen.
Our team is actively working to identify the root cause. In the meantime, clearing your browser cache may help resolve the issue for some users.
We appreciate your patience and will provide a further update as soon as more information becomes available.
Investigating
We are investigating an issue related to our dashboard, in particular, reports of seeing a blank screen. In most cases, clearing the cache is able to resolve the issue.
We will provide another update shortly once we have identified the cause.