Delay for SEPA Payouts
Resolved·Degraded performance

We have confirmed that SEPA payouts and their respective webhooks have now been processed. We apologise for any inconvenience caused.

Mon, May 19, 2025, 01:32 PM
(5 months ago)
·
Affected components
Updates

Resolved

We have confirmed that SEPA payouts and their respective webhooks have now been processed. We apologise for any inconvenience caused.

Mon, May 19, 2025, 01:32 PM

Identified

There is a short delay with today's SEPA Payouts and the respective webhooks. They will be processed shortly, all funds will be settled this afternoon.

Mon, May 19, 2025, 11:22 AM(2 hours earlier)