Unplanned downtime for HSBC and First Direct - Instant Bank Payments
Resolved·Degraded performance

We have confirmed that Instant Bank Payments from HSBC are working as expected again.

Thu, May 1, 2025, 07:55 AM
(2 months ago)
·
Affected components
Updates

Resolved

We have confirmed that Instant Bank Payments from HSBC are working as expected again.

Thu, May 1, 2025, 07:55 AM

Investigating

As of 5 PM UK time on 29/04/2025, HSBC and First Direct Banks are experiencing an unplanned downtime. As a result, they will not appear on the list of institutions for Instant Bank Payments (on the payer’s side). We are monitoring the situation and will update at the earliest.

Wed, Apr 30, 2025, 08:55 AM(23 hours earlier)