Resolved
We haven't observed any loading issues since the fix was applied.
We do not expect any additional disruption.
Monitoring
Our engineers have applied a fix and all pages are now loading successfully.
We are continuing to monitor the situation.
Investigating
We are currently experiencing an outage of our Dashboard and Payment Pages while using the newest version of Google Chrome.
Our engineers have found the root cause and are working towards a solution, if you encounter a page-loading problem, please use another browser as a workaround.