Resolved
Incident has been resolved.
Monitoring
The dashboard logins are back to normal. Our engineers will continue to investigate to identify the root cause.
Investigating
We are currently experiencing slow logins on our dashboard. Our engineers are investigating and we'll provide updates here.