EUR payouts, refunds, and collections
Resolved

Our monitoring shows that our services have stayed stable following the fix our partner bank applied.

We do not expect any additional disruption.

Mon, Jan 23, 2023, 03:26 PM
(2 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

Our monitoring shows that our services have stayed stable following the fix our partner bank applied.

We do not expect any additional disruption.

Mon, Jan 23, 2023, 03:26 PM

Monitoring

We have fixed the issue with our sponsor bank related to EUR payouts, refunds and collections. There are no delays to any payments at this time but we are continuing to monitor the issue.

Fri, Jan 20, 2023, 09:40 PM(2 days earlier)

Identified

We have identified an issue with our sponsor bank related to EUR payouts, refunds and collections. There are no delays to any payments at this time and we are working to resolve this before any customers are affected.

Fri, Jan 20, 2023, 06:40 PM(3 hours earlier)