Payment Pages Partial Outage
Resolved

The underlying issue has been resolved and we've seen a number of successful payments being made.

Wed, Jan 25, 2023, 11:38 AM
(2 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

The underlying issue has been resolved and we've seen a number of successful payments being made.

Wed, Jan 25, 2023, 11:38 AM

Investigating

We are currently experiencing an outage of our Payment Pages. Specifically affecting Instant Bank Pay, Verified mandates and Merchant Bank account verification.

Our engineers are investigating and we'll provide updates here. Updates from the affected Banks suggest this is related to the global Microsoft cloud outages affecting a number of services.

Wed, Jan 25, 2023, 10:19 AM(1 hour earlier)