No components marked as affected
Resolved
We’ve continued monitoring following the earlier Events API issue, and all systems are operating as expected.
Monitoring
We identified an issue affecting a small number of merchants, where queries to the Events API returned no events for payments, payment_actions, or customers created after 29 April. This also impacted the dashboard view for these resources.
The issue has now been resolved, and we are continuing to monitor the situation.