Resolved
We can now confirm that all SEPA Instant payouts for April 14th have been processed and received.
We apologise for any inconvenience caused.
Monitoring
We recently experienced an issue with SEPA Instant Payouts due to a problem with our banking partner. The issue has been resolved, and we’re working closely with them to restore normal service.
Payouts scheduled for this afternoon may be slightly delayed and are expected to arrive at merchants 60–90 minutes later than usual.